17 lines
381 B
Nix
17 lines
381 B
Nix
{ pkgs, ... }:
|
|
|
|
let
|
|
username = "sadorowo";
|
|
fullname = "Franek";
|
|
preferredShell = pkgs.fish;
|
|
in {
|
|
users.users.${username} = {
|
|
isNormalUser = true;
|
|
description = fullname;
|
|
home = "/home/${username}";
|
|
extraGroups = [ "wheel" "networkmanager" ];
|
|
shell = preferredShell;
|
|
ignoreShellProgramCheck = true; # Will do it later in profile configuration
|
|
};
|
|
}
|